Configuration d’un agrégat de liens sous CISCO

Introduction

 

Voici les commandes CISCO pour configurer un agrégat de lien via le protocole LACP, un agrégat (ou port-channel) permettant d’assurer une meilleure tolérance de panne mais aussi d’augmenter la bande passante si celle-ci devient insuffisante.

 

 

 

 

 

 

 

 

 

 

Sur le switch 1 (ports g0/1 et g0/2)

 

Configuration des ports physiques

 

switch1>en
switch1#configure terminal
switch1(config)#interface range g0/1 - 2
switch1(config)#channel-group 1 mode active (ce mode veut dire que l'équipement initiera la connexion lacp)
switch1(config)#channel-protocol lacp
switch1(config)#exit

 

Configuration du port-channel (ici un trunk pour fait passer les VLANS)

 

switch1>en
switch1#configure terminal
switch1(config)#interface port-channel 1
switch1(config)#switchport mode trunk
switch1(config)#no shutdown

 

Ici nous voyons bien que la configuration est identique à ce qu’on pourrait faire sur un port physique.

 

Sur le switch 2 (ports g0/1 et g0/2 également)

 

On applique exactement la même configuration.

 

Configuration des ports physiques

 

switch1>en
switch2#configure terminal
switch2(config)#interface range g0/1 - 2
switch2(config)#channel-group 1 mode active (ce mode veut dire que l'équipement initiera la connexion lacp)
switch2(config)#channel-protocol lacp
switch2(config)#exit

 

Configuration du port-channel (ici un trunk pour fait passer les VLANS)

 

switch2>en
switch2#configure terminal
switch2(config)#interface port-channel 1
switch2(config)#switchport mode trunk
switch2(config)#no shutdown

 

Connectez maintenant le port g0/1 du switch1 avec le port g0/1 du switch2 ainsi que le port g0/2 du switch1 avec le port g0/2 du switch2, paramétrez vos switchs avec une adresse IP et faîtes des tests de ping en enlevant de temps en temps un câble sur deux, vous ne devriez pas avoir de perte de connexion.

 

Commande de visualisation du port-channel (ici l’etherchannel n°1)

 

switch1>en
switch1#show etherchannel 1 summary

3 Commentaires

  1. merci
    mais en environnement physique de quelle manière on peut configurer le switch

  2. Bonjour langpi, qu’entends tu par environnement physique ? Ce tutoriel a été testé dans un environnement physique justement 🙂 sur des switchs CISCO de gamme Catalyst 2950, 2960 3750 …

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *